Cisco LACP Linux

Aus xinux.net
Zur Navigation springen Zur Suche springen

Cisco Switch

Settings

interface Port-channel20
 description lacp-to-doom
 switchport mode access
!
interface GigabitEthernet1/0/47
 switchport mode access
 channel-group 20 mode active
!
interface GigabitEthernet1/0/48
 switchport mode access
 channel-group 20 mode active

Control

  • show lacp 20 internal
Flags:  S - Device is requesting Slow LACPDUs
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode

Channel group 20
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Gi1/0/47  SA      bndl      32768         0x14      0x14    0x130       0x3D
Gi1/0/48  SA      bndl      32768         0x14      0x14    0x131       0x3D

Linux

Settings

auto bond0
iface bond0 inet static
   address 192.168.240.3
   netmask 255.255.248.0
   gateway 192.168.240.100
   bond-mode  802.3ad
   bond-miimon 100
   bond-lacp-rate 1
   bond-slaves none

auto eth1
iface eth1 inet manual
        bond-master bond0

auto eth2
iface eth2 inet manual
        bond-master bond0

Control

cat /proc/net/bonding/bond0

Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: layer2 (0)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

802.3ad info
LACP rate: fast
Min links: 0
Aggregator selection policy (ad_select): stable
Active Aggregator Info:
	Aggregator ID: 2
	Number of ports: 2
	Actor Key: 17
	Partner Key: 20
	Partner Mac Address: 00:19:aa:7d:d8:00

Slave Interface: eth1
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 8
Permanent HW addr: 00:15:17:78:68:16
Aggregator ID: 2
Slave queue ID: 0

Slave Interface: eth2
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 7
Permanent HW addr: 00:15:17:78:68:17
Aggregator ID: 2
Slave queue ID: 0

Links